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一种使用 Image J 重构昆虫感器 

支配神经的方法* 
程振丰 1**  付丙鲜 1***  祝增荣 2  洪  健 3 

（1. 浙江农林大学现代农学院，临安 311300；2. 浙江大学农业与生物技术学院昆虫科学研究所，杭州 310058； 

3. 浙江大学农生环测试中心，杭州 310058） 

摘  要  【目的】 Image J 是一款基于 Java 的完全开源软件，本文通过 Image J 重构昆虫感器支配神经，

以期提供一种开源的三维重构方法。【方法】 Image J 重构包括调整系列图片亮度及对比度、图像校准、

手动绘制填色图片、导入填色图片、通过图形工作站运行 3D Viewer。【结果】 基于 Image J，完成了灰

飞虱触角盘状感器支配神经的三维重构，重构模型生动展示了盘状感器支配神经元组的数量及空间延展关

系。在三维查看器中可旋转、放大三维模型观察精细结构，也可调整阈值观察特定结构，还可调整模型透

明度及模型整体颜色。【结论】 Image J 具有广阔的升级空间和应用前景，有望为昆虫、其他节肢动物及

生物组织的三维重构提供有力支持。 

关键词  Image J 软件；昆虫；感器；支配神经；三维重构 

A method of reconstructing innervating nerves of  
insect sensilla using Image J 

CHENG Zhen-Feng1**  FU Bing-Xian1***  ZHU Zeng-Rong2  HONG Jian3 

(1. College of Advanced Agricultural Sciences, Zhejiang A&F University, Lin’an 311300, China; 2. Institute of Insect Sciences, 

College of Agricultural and Biotechnology, Zhejiang University, Hangzhou 310058, China; 3. Analysis Center of  

Agrobiology and Environmental Sciences, Zhejiang University, Hangzhou 310058, China) 

Abstract  [Objectives]  Image J is a fully open-source Java-based software package. We used Image J to reconstruct the 

dendritic innervations of insect sensilla, thereby providing an open source, three-dimensional reconstruction method. 

[Methods]  We followed the following steps; adjust the brightness and contrast of serial pictures, calibrate images, manually 

add color and import pictures, and finally, run the 3D viewer through a graphics workstation. [Results]  We successfully 

completed 3D reconstruction of the innervating nerves of sensilla placodea on antennae of the small brown planthopper. The 

reconstructed model vividly demonstrates the number of neuronal groups of sensilla placodea and their spatial relationships 

with each other. The 3D viewer allowed images to be rotated and enlarged to observe fine structures, adjustment of the 

threshold value to observe the specific structures and adjustment of the transparency and overall color of the model. 

[Conclusion]  Image J has great potential for application in this field and is expected to provide technical support for the 3D 

reconstruction of the morphology of insects, other arthropods and biological tissues.  

Key words  Image J; insect; sensilla; innervating nerves; three-dimensional reconstruction 
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三维图像比二维图像更容易理解，计算机三

维（Three dimensional，3D）重构是指运用计算

机图形学和数字图像处理技术，将所得二维图像

在计算机中重构出物体的三维图像数据，并显示

所研究对象三维结构的技术（Genoni et al.，

2021）。计算机中的三维模型是物体多视角集合

和几何信息的立体呈现，计算机构造三维模型的

流程一般包括数据获取、三维重构、面重构三部

分，三维重构是三维模型构造的核心计算过程

（Phang et al.，2021）。 

无论是通过各种高分辨荧光显微镜对生物

组织做无损光学切片，还是通过电子显微镜对生

物组织进行有损切片，获取连续数据均是进行三

维重构的第一步。在结构生物学领域，基于低温

透射电子断层扫描（Cryo transmission electron 

tomography，Cryo-TEM）的三维重构，已经分

化发展为三种具有各自特点和适用范围的方法：

电子断层三维重构技术（Electron tomography）

适用于不具有全同性的超分子和亚细胞体系；单

颗粒三维重构技术（Single particle analysis）用

于解析具有全同性的蛋白质分子的三维结构；电

子晶体学（Electron crystallography）主要处理二

维晶体样品（张凯等，2010；Strunk，2012）。低

温透射电子显微镜技术，具有能保持样品近生理

状态、能重构出高分辨率三维结构的特点（程凌

鹏，2018），但对设备、样品的要求较高，且更

适合病毒颗粒等小分子样品。在更大尺度空间重

构生物组织结构，最开始基于透射电镜连续切片

技 术 （ Serial section/transmission electron 

microscopy，SSTEM），但由于切片、染色、电

子束损伤等种种原因，使得该工作非常耗时耗力

且具高难度挑战性，目前基于此技术进行三维重

构的研究报道非常罕见，应用于昆虫方面的研究

更是稀少（Stefan et al.，2021）。在过去 20 年里，

随着计算机运行计算能力的提高、复杂的显示选

项和新仪器的发展，带有内置切片机的扫描电

镜、聚焦离子束扫描电镜使得对样品进行连续切

片和 3D 分析变得更加容易和快速，而基于聚焦

离子束扫描电镜（Focused ion beam/scanning 

electron microscope，FIB-SEM）的断层扫描技术

具有最广泛的应用前景（Kizilyaprak et al.，

2014）。基于聚焦离子束的连续块面扫描电镜技

术（Focused ion beam/serial block face scanning 

electron microscopy，FIB-SBFSEM）填补了使用

高端荧光显微镜的 3D 成像和电子断层扫描提供

的高分辨率之间的空白（Hughes et al.，2014），

具有 Z 轴分辨率高、自动化程度高等特点，主要

应用于细胞水平研究，在获得大尺度样品数据信

息上显示出了巨大优越性（李晓敏，2020）。 

上述各种技术获取的连续数据，通过计算机

三维重构可得到样本的三维模型。用于计算机三

维重构的软件有 Amira、Avizo、IMOD、Image J

等，其中 Amira 具有良好的三维重构效果，也是

应用最多的软件，在生物医学领域可用于动脉粥

样硬化组织的三维重构（Hekking et al.，2009）

或计算机断层扫描（Computed tomography，CT）

图像的三维重构（徐凯等，2011）。Avizo 功能与

Amira 类似，但与 Amira 专用于生命科学不同，

Avizo 多在材料学中有所应用，如利用 Avizo 重

构材料的内部孔洞（Long et al.，2017）。IMOD

是由 Kremer 等（1996）开发的用于电子显微镜

或光学显微镜连续切片的三维重构软件，应用不

及 Amira 和 Avizo 广泛，但 IMOD 属于非商用软

件，具有使用简便的特性。Image J 是由美国国

立卫生研究院（National institutes of health，NIH）

在 1987 年开发的基于 Java 的完全开源的图像处

理软件，能处理和保存诸如 TIFF、JPEG、GIF、

BMP 等多种格式的图片，具有功能强大、操作

简便的特点（Schindelin et al.，2012）。Image J

具有多种强大的功能，包括但不限于图片的分

割、标注、旋转、裁剪及面积计算和数量统计等

功能，也能用于三维图像的构造和处理（张培等，

2012）。Image J 的优势还在于支持一系列插件的

使用，从最初的 Image J1 到目前的 Fiji（在 Image 

J1 的基础上增加了许多功能和插件后的软件，文

中提到的 Image J 均指 Fiji），经过几十年的发展，

Image J 功能强大的插件数量已达数百种并形成

了 Image J 生态，具有广阔的应用发展前景

（Schroeder et al.，2020）。Image J 在生命科学

中已有较多应用，特别是在医学方面，Image J

可用于人体烧伤皮肤伤口面积的测量（鲁晋，

2017）、人体皮肤-微观结构的三维重构等（陈伟



1 期 程振丰等: 一种使用 Image J 重构昆虫感器支配神经的方法 ·215· 

 

 

等，2017）；Image J 也成功用于果蝇 Drosophila

幼虫中枢神经系统的三维重构（Cardona et al.，

2010）。在材料学方面，Image J 可用于显微组织

结构连续切片图像三维空间的处理、分割、分析

研究（Asad et al.，2012）。 

三维重构已广泛应用于昆虫学研究，如昆虫

嗅觉神经的三维重构（付丙鲜和祝增荣，2008）；

近 来 开 展 的 相 关 研 究 有 双 斑 蟋 Gryllus 

bimaculatus 触角叶神经纤维球的三维重构，呈现

出神经纤维球的位置、大小关系（武健文，2012）；

果蝇脑的三维重构（Cardona et al.，2010）；捻翅

目昆虫单侧眼的三维重构及利用模型测量其体

积（Stefan et al.，2021）；关于家蚊触角叶的三

维重构（Ye et al.，2020）；褐飞虱 Nilaparvata 

lugens (Stål) 的内部三维结构已经得到完整重构

（Wang et al.，2021），清晰地展示了褐飞虱内部

各种器官的位置关系，并以一种新模式揭示了褐

飞虱对水稻危害机制；另外褐飞虱腹板上的毛状

感器被成功三维重构，重构的三维模型展现了刺

形感器所具有的机械性刺激感受器的一般特征

（Guo et al.，2019）。三维重构技术在灰飞虱

Laodelphax striatellus (Fallén) 的研究中亦有所

涉及（Fu，2013）。昆虫学三维重构研究中的常

用软件为 Amira，但其购买及使用费用较高。

Image J 软件完全开源，且支持多种跨平台插件

的使用（Schindelin et al.，2012），使得其在昆虫

学研究中具有巨大潜力。因此，本文使用 Image 

J，以 FIB-SEM 即 FIB-SBFSEM 所获得的数据

集为例，介绍了一种开源的三维重构计算方法，

以期为昆虫、节肢动物及生物组织的三维重构提

供有力支撑。 

1  材料与方法 

1.1  图形工作站 

三维重构于图形工作站中进行，图形工作站

1 配置如下：CPU 为 AMD Ryzen 5 1600，显卡

为 GTX 1060 6 GB，运行内存为 16 GB，主板为

微星 B350M PRO-VD PLUS；图形工作站 2 配置

如下：CPU 为 Intel Core i5 7200，显卡为 AMD 

Radeon R5 M530，运行内存为 4 GB，主板为 7th 

Generation Intel Processor Family I/O-9D58。本研

究中图片的预处理和选区操作在图形工作站 1

中运行，三维重构的过程在图形工作站 2 中运行。 

1.2  Image J 软件 

Image J 即 Fiji。本研究所使用 Image J 是

Window10 操作系统的 64 位版，于官网下载

（https://imagej.net/Fiji/Downloads）。此外研究中

用到的 Image J 插件 Image Stabilizer 于官网下载

（ http://www.cs.cmu.edu/~kangli/code/Image_Sta

bilizer.html）。 

1.3  处理图像的获取 

本研究所用系列图片由双束扫描电镜（Fei 

Helios Nanolab 600i）进行收集。将整体染色的

灰飞虱触角树脂包埋块置于倾斜样品台上，适量

涂抹银胶，喷碳处理后置入双束扫描电镜中进行

连续块面扫描，获得 336 张扫描电镜图像，图像

主要内容为灰飞虱触角盘状感器的支配神经元

及其附属细胞。 

1.4  Image J 软件的下载与安装 

所用 Image J软件为官方网站（https://imagej. 

net/Fiji/Downloads）下载的 Windows 版 64 位，

将名为“fiji-win64.zip”的压缩包解压缩即得到

Image J 软件。打开解压后的文件夹找到.exe 的

Image J 程序，双击即可使用软件。 

2  结果与分析 

2.1  Image J 界面及功能简介 

双击 Image J 打开软件后，软件界面如图 1

所示，Image J 菜单下方是各种快捷工具，主要

是各种选区工具。选区工具有“Rectangle”、“Oval 

selections”、“Polygon selections”、“Freehand 

selections”、“Straight line”、“Angle tool”、“Point 

Tool”、“Wand Tool”等。单击鼠标左键选中并

使用这些工具，双击鼠标左键可对选区工具做一

些设置，如左键 Oval selections 可更改选区工具

笔刷的像素大小，左键 Wand Tool 工具可调整容
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差大小等，快捷工具的图标右下角有三角形小红

标则代表快捷工具有子菜单，选中某个选区工具

后单击鼠标右键可更改选区工具为子菜单工具。 

Rectangle 是矩形选区工具，用来选择矩形

选区，其子菜单下还有“Rounded Rectangle”和

“ Rotated Rectangle ” 选 区 工 具 ， Rounded 

Rectangle 用于选择四角圆滑的矩形选区，

Rotated Rectangle 用于选择菱形选区。Oval 

selections 用于形成圆形或椭圆形选区，子菜单

下有“Elliptical selections”和“Selection Brush 

Tool”，Elliptical selections 可创造固定比例但可

任意调节大小的椭圆形选区，Selection Brush 

Tool 类似于笔刷，可创造任意形状的选区，本研

究主要使用工具为 Selection Brush Tool。Polygon 

selections 以多根直线相连的方式创造选区，

Freehand selections 以手动画线的方式创造任意

形状的选区。Straight line 即创造一根直线，用

于辅助创造选区，Straight line 子菜单下有

“Segmented Line”、“Freehand Line”和“Arrow 

Tool”，Segmented Line 的选区功能类似 Polygon 

selections，但 Segmented Line 不会自动形成闭合

选区，Arrow Tool 即创造一个带箭头的直线，用

于标示特定结构，和 Straight line 一样不具有形

成闭合选区的功能。Angle tool 即创造一个可调

整大小的角，无法形成闭合选区。Point Tool 及

其子菜单下的 Multi-point Tool 能创造一个带数

字的点选区，起到辅助计数的作用。Wand Tool

即根据图片之间的容差大小快速区分颜色差距

较大的部分而快速创造选区。Image J 中对选区

的一些快捷操作：Edit>Selection>Select all（快

捷键 ctrl+A）选中整张图片为选区， Edit> 

Selection>Select none（快捷键 ctrl+shift+A）可

清除图片中的所有选区。 

综合以上选区工具，鉴于 Selection Brush 

Tool 能选取任意形状的选取且易于修改，选用

Selection Brush Tool作为本研究的主要选区工具。 
 

 
 

图 1  Image J 界面 

Fig. 1  The interface of Image J 
 

2.2  导入图片 

在 Image J 界面通过 File>Open（快捷键 ctrl+ 

O）可导入 TIFF、PNG、GIF、JPEG、BMP 等

格式的文件，也可将一张或多张图片直接拖曳到

Image J 界面打开。File>Import>Image Sequence

可导入一个文件夹中的全部图片并将文件夹中

的图片按顺序组成 Stack（Stack 指图片堆栈，能

在 Image J 中显示和处理），File>Import> AVI 可

导入 AVI 格式的视频文件。 

File>Save（快捷键 ctrl+S）将图片保存为

TIFF格式，该步骤等同于File>Save AS>Tiff。File> 

Save As>AVI 可将 Stack 保存成 AVI 格式的视频。 

2.3  图片预处理 

2.3.1  调整图片衬度  双击 Image J 打开软件，

首先导入图片（原图片为 TIFF 格式）。通过

Image>Adjust>Brightness/Contrast （ Brightness/ 

Contrast 对话框如图 2：A）可调整单张图片的亮

度和对比度实现，Brightness/Contrast 的调整通

过 Minimum/Maximum 值的变化来实现。本处理

中通过运行程序将 Brightness/Contrast 界面中的

Minimum 值调整为 45，将 Maximum 值调整为

245，实现对导入图片亮度、对比度的批量调整，

从而达到图片衬度的批处理效果。程序的运行操

作如下：Process>Batch>Macro 打开批处理对话

框（图 2：B），Input 处选择“导入文件夹”，Output

处选择“导出文件夹”，Output format 选择 TIFF，

Add macro code 处选择[Select from list]，批处理界

面最下方的空白处输入宏代码“run ("Brightness/ 

Contrast..."); setMinAndMax(45, 255); run("Apply 
LUT"); run("Close");”，点击 Process 即实现图片
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的批量衬度调整。相关宏代码可于 Plugins> 

Macros>Record 中进行相关操作获取。 

2.3.2  图片校准  此步骤需要用到 Image J 的

Image Stabilizer 插件，该插件可于官网自行下载

（ http://www.cs.cmu.edu/~kangli/code/Image_Sta

bilizer.html），将下载到的两个 Image_Stabilizer. 

class 和 Image_Stabilizer_Log_Applier.class 文件

放置在 Image J 安装目录的 Plugins 文件夹中，然

后重新打开 Image J 软件，即可在 Plugins 菜单下

找到 Image Stabilizer。使用 Image J Stabilizer 需

要先在 File>Import>Image Sequence 导入需要校

准的图片序列，导入序列后在 Sequence Option

处勾选“Use virtual stack”（图 2：C，勾选是由

于图片序列较大，图片序列小可不勾选），此时

打开 Image Stabilizer 会提示选择输出文件夹，点

击“OK”并选择文件夹，弹出 Image Stabilizer

对话框（图 2：D），点击“OK”，等待校准后将

图片导出即可。 

2.4  选区操作 

打开经过预处理的图片，通过 Analyze> 

Tools>ROI Manager 打开 ROI Manager 窗口（图 

 

 
 

图 2  图片预处理 

Fig. 2  Image preprocessing 

A.“亮度/对比度”对话框；B. Image J 的批处理对话框； 

C. 导入图片序列时选择“使用虚拟堆栈”；D.“图片校准器”对话框。 

A. The dialogue box of brightness/contrast; B. The dialogue box of batch process of Image J;  
C. Choosing “Use virtual stack” when import sequence; D. The dialogue box of “Image Stabilizer”. 
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3：A）。选择“Wand Brush Tool”工具选择目标

选区（单个选区如图 3：B），可通过该工具精确

调整选区边界。点击 ROI Manager 处“Add it”

即可添加选区，重复操作可选取并添加多个选

区。ROI Manager 窗口内勾选“Show All”可显

示所有选区（图 3：C），勾选“Labels”会按添

加顺序显示各个选区的标签。鼠标左键点击 ROI 

Manager 内的单个选区，ROI Manager 处点击

Rename 可对选区进行重新命名，点击 Delete 可

删除选区，对单个选区进行重新操作后点击

Upgrade 可显示更改后的选区，点击 Properties

弹出对话框（图 3：D），在对话框的 Fill color

处可通过输入某种颜色的英文名称或十六进制

颜色码改变选区内的颜色。鼠标选择单个选区后

按住 Ctrl 再点击其他选区即可选择多个选中选

区，通过 Properties 可更改所有选中选区的颜色，

More> Save 可保存选区。将所有目标选区填上

需要颜色后，选择 Edit>Clear Outside，再点击

ROI Manager 处的 Flatten，得到填色图片（图 3：

E）并保存。选中多个选区后可通过 ROI Manager

窗口的 More> Combine 将所有选区合并，

More>Open 可以打开之前保存的选区，继续进一

步操作。 

重复以上选区操作，将 ROI 区域都选出来， 

 

 
 

图 3  选区操作 

Fig. 3  The process of choosing ROI (Region of interest) 

A. 选区管理器窗口；B. 一个单独的选区；C. “选区管理器”中勾选“显示全部选区”和“标签” 

显示的所有选区；D. 选区管理器中“属性”对话框；E. 支配神经元组的填色图片。 

A．The window of ROI Manager; B. A single ROI; C. The all ROIs after choosing “Show All” and  

“Labels” in ROI Manager; D. The dialogue box of Properties in ROI Manager;  
E. The color-filled picture of groups of dendritic innervations of neurons. 
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绘制出 336 张电镜图的填色图片即获得用于三

维重构的图片序列。 

2.5  三维重构 

得到所有特定选区的填色图片后，将所有图

片按 File>Import>Image Sequence 导入，打开

Image>Properties，调节弹出窗口处的“Voxel 

depth”值（图 4：B），即可调节 3D Viewer 中的

Z 轴距离，具体“Voxel depth”值大小根据切片

的实际间隔距离而定，本研究的“Voxel depth”

值为“5.0000”。选择 Plugins>3D Viewer（图 4：

A）查看三维结构。在 3D Viewer 窗口选择 View> 

Record 360 deg rotation 后会弹出一个“Movie”

窗口，点击播放按钮可以观察重建模型旋转 360

度的 Movie（图 4：C），通过 File>Save As>AVI

可将该 Movie 以 AVI 视频格式保存。 
 

 
 

图 4  三维重构 

Fig. 4  Three-dimensional reconstruction 

A. 打开三维查看器后出现的对话框；B. 选择“图片>属性”后打开的对话框； 

C.“影像”窗口展示了多组支配神经的三维重构模型。 

A. The dialogue box that appears after opening the 3D Viewer; B. The dialogue box appears after choosing 
'Image>Properties’; C. The window of Movie showing the 3D model of several groups of innervating nerves. 

 

3  讨论 

近年来随着显微镜技术的提升，图像数据的

数量和复杂性已达到必须利用计算机才能提取

其中信息的地步，其中依靠软件进行三维重构是

生物学家较为常用的一种方案（Schindelin et al.，

2012）。FIB-SEM 技术所使用的表面树脂包埋组

织具有浮雕状拓扑结构，故样品中的感兴趣区域

（Region of interest，ROI）可被 FIB-SEM 技术

成像并用于三维分析（Kizilyaprak et al.，2014），

由此寻找便捷的三维重构技术成为必要。 

三维重构的主流软件常为澳大利亚 Visage 

Imaging 公司出品的 Amira、Avizo 软件，软件本

身不开源且较昂贵，而 Image J 是完全开源的免 

费软件，另外 Image J 具有对非专业人员友好、

操作简单且大部分操作不占用太大运行内存的

特性，是一个值得推荐的图像处理软件。Image J

在三维重构领域的应用已经有不少案例，如用于

捻翅目昆虫单侧眼三维重构研究中的图片校准、

ROI 结构选择和数据的测量计算均利用 Image J

完成（Stefan et al.，2021）；多种生物神经回路

的三维重构也都利用了 Image J：果蝇中枢神经

系统的三维重构、猫视觉皮层中的丘脑-皮质连

接的三维重构以及小鼠视觉皮层的三维重构

（Cardona et al.，2012），这些研究表明 Image J

软件应用于昆虫神经学具有可行性。因此，本文

采用 Image J 对灰飞虱感器支配神经进行三维重

构，展示了 Image J 的三维重构功能在多种情况 
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下都具有较好的便捷性。Image J 三维重构通过

其中的 3D Viewer 插件实现，所有涉及的操作步

骤简单易实现，能很快完成三维重构，且对硬件

的要求不高。在 3D Viewer 中可以旋转、放大三

维模型从而观察结构，也可调整阈值观察特定结

构，还可调整模型透明度及模型整体颜色。3D 

Viewer 可通过记录模型 360 度旋转的一系列图

片的方式，以 AVI 视频格式导出而保存三维模

型，导出时 Image J 自带压缩功能，导出的 AVI

视频占用内存较小，这些都使得 3D Viewer 具有

超高的实用性。 

Image J 的便捷性不局限在三维重构，它是

一个具有丰富功能的图像处理软件。Image J 的

应用主要集中在医学图像研究、神经生物学、细

胞生物学等方面，特别是在神经回路重构方面已

有诸多报道（Cardona et al.，2012）。本研究将

Image J 引入到昆虫神经研究中，在研究昆虫微

观结构和电镜图片的处理方面发挥了良好的作

用。Image J 的开源性使其拥有优质的应用插件

（Schindelin et al.，2012），具有广阔的升级空间

和应用前景，加强对 Image J 的学习，亦能在提

高图像处理能力的同时扩展自身的知识储备。通

过 Image J 可较为便捷地实现三维重构，但目前

有关 Image J 的系统学习资料仍十分缺乏，且其

普及程度也较低，因此有关 Image J 在三维重构

中的应用尚需深入研究。另外，通过 Image J 重

构的三维模型在精细度方面与传统三维重构软

件 Amira、Avizo 相比仍有不足。但在昆虫学研

究中，完全可以引入 Image J，以实现对昆虫组

织数据集的三维重构，Image J 有望在昆虫器官

形态功能（Chitsaz et al.，2020）、昆虫神经网络

结构（Xie et al.，2019）、昆虫感受器分布及功

能等研究中发挥重要作用。 
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